iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download the free app XperGuide by Philips, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

XperGuide

By Philips

Open iTunes to buy and download apps.

Description

Practice your image guided needle intervention skills in an interactive virtual lab simulation with the Philips XperGuide mobile app.
The Philips Healthcare XperGuide application provides an interactive virtual simulation that helps Physicians and Technologists increase their knowledge and skills, and realize a more efficient workflow by performing needle procedures in the interventional suite. This mobile application includes passive simulation modules that allow you to discover how to set up a rotational scan for image acquisition and perform percutaneous needle procedures with live 3D image visualization. It also includes a series of active simulation modules that give you the chance to practice newly acquired skills in a safe virtual environment where assistance is always available by touching the “Show Me” button. Plus, you can hear testimonials from users who have applied XperGuide to their daily practice.

With the Philips XperGuide application and virtual lab simulation, now you can explore and practice XperCT and XperGuide at your own pace and master your interventional skills anywhere and at any time

What's New in Version 1.2.1

Share with your friends

iPad Screenshots

iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
XperGuide
View in iTunes
  • Free
  • Category: Medical
  • Updated:
  • Version: 1.2.1
  • Size: 104 MB
  • Languages: English, Czech, Dutch, French, German, Italian, Japanese, Korean, Polish, Portuguese, Russian, Simplified Chinese, Spanish, Swedish, Traditional Chinese, Turkish
  • Developer:

Compatibility: Requires iOS 4.0 or later. Compatible with iPad.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.