Mac App Store

Mac App Store

Mac App Store is the simplest way to find and download apps for your Mac.

To download EventScripts from the Mac App Store, you need a Mac with OS X 10.6.6 or later. Learn More.

EventScripts

By David Blishen

Open the Mac App Store to buy and download apps.

Description

EventScripts triggers scripts whenever monitored events occur. AppleScripts, Automator workflows, Perl scripts, shell scripts and applications can all be executed by EventScripts.

EventScripts can also remote control your Mac by triggering scripts using your Apple Remote control. You can even run scripts from your iPhone, iPad or iPod Touch using the free companion application EventScripts Mobile.

EventScripts is also scriptable allowing you to use EventScripts to send Prowl and Pushover notifications to your iOS device.

EventScripts passes parameters to all the scripts that it executes that provide additional information about the event that triggered execution.

The events that EventScripts supports include:

Bluetooth device proximity; Apple Remote Button presses;
Location changes; internet connectivity changes; application launches and quits; computer shutdown; file downloads; sleep and wake; screen sleep, wake and locking; screensaver start and stop; time machine backup completion; bluetooth availability; wifi network name changes; iTunes track changes; screenshot generation; volume mounting and ejection and many many more…

Our web site contains many useful example scripts for controlling Plex, VLC, QuickTime, Powerpoint, Transmission as well as templates for writing your own scripts.

Check out website for full details.

What's New in Version 1.10

* Improved control over bluetooth triggering
* Control over EventScripts logging verbosity
* General bug fixing

Screenshots

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4
Screenshot 5
EventScripts
View in Mac App Store
  • $3.99
  • Category: Utilities
  • Updated: Oct 02, 2013
  • Version: 1.10
  • Size: 4.4 MB
  • Language: English
  • Seller: David Blishen

Compatibility: OS X 10.8 or later, 64-bit processor

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.
All Versions: