iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

Miss Fix-It

This book can be downloaded and read in iBooks on your Mac or iOS device.

Description

A hot cop, a handywoman in killer heels, and a not-so-idle threat… it's going to take more than a pink hammer to fix-it.

Veronica, a self confessed girly-girl, often finds herself labelled a bimbo—and just doesn't care. An ex-economist turned handyperson, Vee is not afraid to be female, period. So what if it happens to be in a male-dominated industry?

When Vee threatens a client with a hammer to ward off his wandering hands, she finds herself at the local police station facing charges of assault. There she meets Detective Cole Samuels, and the sparks thrown off by their mutual animosity are combustive. They quickly become involved in a hot and heavy relationship, leaping one hurdle after another. Things finally seem to be working out when Vee's workplace is vandalized, a message left... and suddenly, that crank call and the near-miss with the crazy driver don't seem to be harmless incidents anymore. Vee's stalker rapidly escalates in violence, leaving Cole determined to find him before Vee gets hurt....

Miss Fix-It
View in iTunes
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Romantic Comedy
  • Expected Release: 13 July 2018
  • Publisher: Louisa Masters
  • Seller: Draft2Digital, LLC
  • Print Length: 311 Pages
  • Language: English
  • Requirements: To view this book, you must have an iOS device with iBooks 1.5 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.