iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download the free app Mercedes-Benz catalogs by Daimler AG, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Mercedes-Benz catalogs

By Daimler AG

Open iTunes to buy and download apps.

Description

The new Mercedes-Benz vehicle brochures offer a compelling blend of spectacular vehicle images and detailed information.

The optimised Brochures app allows you to experience all the fascination of Mercedes-Benz passenger cars up close and personal. Each brochure has been perfectly configured for your device, while the addition of multimedia features such as films, as well as a range of interactive and individual functions, adds even more to their appeal. The contents offer highlights for all the senses: enjoy a comprehensive package of information, animations and stunning photography, and use the integrated configurator to create an enduring image of the exclusive interior, sporty light-alloy wheels and high-quality paint finishes.

Join the fascinating world of Mercedes by loading the app today!

What's New in Version 3.2.1

Stabilization and bug fixes

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
Mercedes-Benz catalogs
View in iTunes
This app is designed for both iPhone and iPad
  • Free
  • Category: Catalogues
  • Updated:
  • Version: 3.2.1
  • Size: 68.8 MB
  • Languages: English, Arabic, Danish, Dutch, French, German, Italian, Norwegian Bokmål, Polish, Portuguese, Russian, Simplified Chinese, Spanish, Swedish, Turkish
  • Developer:

Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.