iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download EU VAT Validator Live! by Netquest, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

EU VAT Validator Live!

By Netquest

Open iTunes to buy and download apps.

Description

“EU VAT Validator Live!” allows you to validate a European VAT (Value Added Tax) number live!

It connects to the official VIES VAT validation system of the European Commission Taxation and Customs Union and checks the validity of the VAT number issued by a Member State. If the number is valid then the company information (name and address) that is associated with the number is displayed. In addition it allows you to easily e-mail that information to anyone.

Currently the following countries are supported:
Austria, Belgium, Bulgaria, Cyprus, Czech Republic, Denmark, Estonia, Finland, France, Germany, Greece, Hungary, Ireland, Italy, Latvia, Lithuania, Luxembourg, Malta, The Netherlands, Poland, Portugal, Romania, Slovakia, Slovenia, Spain, Sweden, United Kingdom.

The app requires an Internet Connection to validate a European VAT number. We accept no responsibility or liability whatsoever with regard to the information obtained using this iPhone app.

What's New in Version 2.0

Now validates correctly.
Service was broken due to changes in the EU Online validator.

iPhone Screenshot

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3

Customer Reviews

Very good and help full

Help full to check genuine company
Thanks
LAREEF

EU VAT Validator Live!
View In iTunes
  • £0.79
  • Category: Business
  • Updated:
  • Version: 2.0
  • Size: 0.5 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 3.0 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.