iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download the free app Museum of London Postcards by Pogopost, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

Museum of London Postcards

By Pogopost

This app is only available on the App Store for iOS devices.

Description

Create your own real postcards from a variety of beautiful shots specially selected from the Museum of London's image archive, or use your own photograph. Try out the 'postcards near me' feature to see Museum of London images around you throughout London. Write a message, scribble your own signature and add an address. We will then print your personalised postcard and post it out within 24 hours by Royal Mail. Each postcard costs £1.50 plus postage and helps to support the Museum of London.

The postcards are printed on 300 gsm stock using the best quality inks with state of art printing technology. All paper is sourced from sustainable forests.

The Museum of London image archive is a unique collection of over 35,000 images illustrating the history of London and the life of its people from prehistoric times to the present.

Every purchase goes towards maintaining the Museum of London and its collections.

What's New in Version 2.0

postbox functionality, ios11 compatible

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
Museum of London Postcards
View in iTunes
This app is designed for both iPhone and iPad
  • Free
  • Category: Lifestyle
  • Updated:
  • Version: 2.0
  • Size: 19.2 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad and iPod touch.

Customer Ratings

This application has not received enough ratings to display a summary.