iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download PA-31-350 with VGs Weight and Balance Calculator by Alicia Sikes, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

PA-31-350 with VGs Weight and Balance Calculator

By Alicia Sikes

Open iTunes to buy and download apps.

Description

A weight and balance calculator for the Piper Navajo PA-31-350 with Vortex Generators/Panther Conversion. Tabs are available for Executive, Commuter, and Cargo Only configurations. Entries for both inboard and outboard fuel tanks are available.

Enter the weight (in pounds) for each position in the aircraft, and the amount of fuel (in gallons), and the calculator will let you know if you are out of limits on weight or CG. The forward and aft CG limits are calculated using formula derived from the aircraft limit chart. Correct cargo and bag loading is verified.

If proposed fuel burn is entered (in gallons), landing CG and landing weight are checked. Burn for both the inboard and outboard tanks should be entered. Proper cargo loading positions are also checked- overloads give alert messages and are flagged.

Bonus material! A quick reference for the aircraft V-speeds and other interesting aircraft specific numbers

What's New in Version 1.5

updated data persistence, modified limit checking to be done via button press

iPhone Screenshot

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
PA-31-350 with VGs Weight and Balance Calculator
View In iTunes
  • £7.99
  • Category: Utilities
  • Updated:
  • Version: 1.5
  • Size: 0.7 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 3.1.3 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.