iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download Spelling Shed by Robert Smith, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Spelling Shed

By Robert Smith

Open iTunes to buy and download apps.

Description

Introducing The Spelling Shed from The Literacy Shed Ltd. Designed by a team of Primary School teachers, with primary school students, teachers and parents in mind this app has been created with the key National Curriculum objectives in mind and will take children through the statutory and non-statutory spelling lists in each age phase.

- Learn at your own pace
- Dyslexia friendly
- 1100+ words
- FULL coverage for year 1-6
- Easy to use tools for teachers to create their own spelling lists

This app has been developed to be ‘dyslexia friendly’ using the ‘Open Dyslexic’ font.

With over 1200+ spellings from the National Curriculum teachers will be able to track pupils progress through the objectives from Y1 – Y6

The app is fully customisable through the ‘Your Lists’ section which allows teachers and students to import custom lists.

With three levels of game play, the app supports pupils of all abilities through the spelling lists with various degrees of challenge.

What's New in Version 1.1.3

Bug fixes

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
Spelling Shed
View in iTunes
This app is designed for both iPhone and iPad
  • £2.99
  • Category: Education
  • Updated:
  • Version: 1.1.3
  • Size: 45.4 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.
All Versions: