iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download Cart Cow HD by Gamesmold, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Cart Cow HD

By Gamesmold

Open iTunes to buy and download apps.

Description

Draw grounds that lead Lazy Linda's shopping cart on a breakneck ride into the level exit.
Beware of animals and obstacles that might get into your way - or cleverly use their abilities to speed up your trip!
Collect helpful items to power up cart and cow.
Discover 60 levels, packed with many different game elements and landscapes...

Beware: Some levels are even larger than the drawing area - so take a good aim to shoot the cow into the right place!

Win medals for great performances!

iPadGames.org:
"You have to get this game! It’s crazy, tons of fun, and a blast to play over and over again."

Pocket full of Megabytes Game of the week 2/15/2011(pocketfulofmb.com):
"It’s a simple concept that is deceptively addicting"

1888freeonlinegames.com:
"Cart Cow HD is an easy and fascinating iPad game"

Encroyable.com:
"It’s an absolutely hilarious game, that will have you chuckling all by your lonesome like some kind of lunatic. But who cares as long as you’re enjoying and having the time of your life – which you most certainly will.
(...) This is a must buy game"

What's New in Version 1.2.2

No more banner advertising: Get the full version right from the start!

iPad Screenshots

iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
Cart Cow HD
View In iTunes
  • 1,99 €
  • Category: Games
  • Updated:
  • Version: 1.2.2
  • Size: 14.0 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 5.0 or later. Compatible with iPad.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.
All Versions: