iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download the free app Afterburn 2150: 3D space shooter by Psychic Software, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Afterburn 2150: 3D space shooter

By Psychic Software

Open iTunes to buy and download apps.

Description

The 3D space shooter that takes you on a tour of the solar system while blasting aliens. Retro gameplay action: if you like afterburner, wing commander, and galaxian, you'll love Afterburn 2150.

Featuring 3D sound effects - headphones recommended so you can hear where your enemies are when they're behind you.

Supports the 60beat gamepad.

Universal binary and HD.

26 types of spaceship! (7 can be unlocked and used by the player)
13 planets and moons, plus asteroid belt and deep space levels

Power-ups
------------
Afterburn: makes your ship faster and more agile
Shields: defends your ship from enemy bullets
Rapid fire: makes your guns shoot faster
Multi fire: releases 5 bullets at once
Guided fire: each bullet chases the nearest enemy
Bomb: damage all enemies with an energy pulse

What's New in Version 1.0.3

Improved camera tracking

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
Afterburn 2150: 3D space shooter
View in iTunes
This app is designed for both iPhone and iPad
  • Free
  • Category: Games
  • Updated:
  • Version: 1.0.3
  • Size: 17.0 MB
  • Languages: English, French, German, Italian, Portuguese, Spanish
  • Developer:
Rated 9+ for the following:
  • Infrequent/Mild Cartoon or Fantasy Violence

Compatibility: Requires iOS 4.3 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.