iTunes

Opening the iTunes Store.If iTunes doesn’t open, click the iTunes icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download Ultim8 Loony Laws by Ultim8 Soft, get iTunes now.

Do you already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Ultim8 Loony Laws

By Ultim8 Soft

Open iTunes to buy and download apps.

Description

Ultim8 Loony Laws contains a lot of really wacky laws from all over the world. It contains laws like:

* A barber is not to advertise prices in the State of Georgia.
* A law in Detroit, Michigan, prohibits crocodiles from being tied to a fire hydrant.
* Carriage horses in Charleston, South Carolina, were required to wear diapers.

This version contains the following features:
* 1473 hand-picked and revised funny laws
* Navigate through laws in both directions
* Go to a random law
* Send the laws you like to friends by email
* Save your favorite laws and browse through them
* Share your favorite laws on facebook and twitter
* Swipe back and forth instead of using buttons


We are working on more great features and adding more more to the app.

Disclaimer: Even though we hand picked each and every law in this application, and that we worked hard to validate them, but we take no responsibility if any of the laws included in this application turns out to be faulty.

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
Ultim8 Loony Laws
View In iTunes
This app is designed for both iPhone and iPad
  • USD 0.99
  • Category: Entertainment
  • Released:
  • Version: 1.3
  • Size: 1.2 MB
  • Language: English
  • Developer:

Compatibility: Requires iOS 3.1.3 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.