Mac App Store

Mac App Store is the simplest way to find and download apps for your Mac.

To download Penny Arcade Adventures: Precipice of Darkness from the Mac App Store, you need a Mac with OS X 10.6.6 or later. Learn More.

Penny Arcade Adventures: Precipice of Darkness

By Hothead Games Inc.

Open the Mac App Store to buy and download apps.

Description

Based on the popular and superb web comic strip Penny Arcade, get ready to join with Gabe and Tycho of the Startling Developments Detective Agency.

Solve strange mysteries that are lurking in this fantastic 1st episode. Episode 2 also available on the Mac App Store.

Set in the 1920s, this RPG adventure places the familiar Penny Arcade protagonists in an alternate pulp horror setting reminiscent of the works of H. P. Lovecraft. A must for all Penny Arcade fans!

REVIEWS
"84% - Partnering with developers Hothead Games, Penny Arcade co-conspirators Jerry "Tycho" Holkins and Mike "Gabe" Krahulik have produced a work of gaming art that will ultimately strike the right chord with their fanbase" Cheat Code Central

"82% - ...if you are looking for a few good laughs and an interesting story line packed into a five- to eight-hour package, you really won't find anything better than this" Worth Playing

"80% - It’s a lot like playing a comic strip!" Games Radar

What's New in Version 1.2

Bug Fixes and Enhancements

Screenshots

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4
Screenshot 5
Penny Arcade Adventures: Precipice of Darkness
View in Mac App Store
  • 3,99 €
  • Category: Games
  • Updated:
  • Version: 1.2
  • Size: 246 MB
  • Developer:
You must be at least 17 years old to download this application.
  • Frequent/Intense Mature/Suggestive Themes
  • Infrequent/Mild Horror/Fear Themes
  • Frequent/Intense Cartoon or Fantasy Violence
  • Frequent/Intense Profanity or Crude Humor
  • Infrequent/Mild Alcohol, Tobacco, or Drug Use or References

Compatibility: OS X 10.6.6 or later

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.