Mac App Store

Mac App Store is the simplest way to find and download apps for your Mac.

To download Batman: Arkham Asylum from the Mac App Store, you need a Mac with OS X 10.6.6 or later. Learn More.

Batman: Arkham Asylum

By Feral Interactive Ltd

Open the Mac App Store to buy and download apps.

Description

Welcome to the Madhouse!

Before you buy, expand this description to check the system requirements below.

Descend into the core of the criminally insane as the Joker seizes control of Arkham Asylum and launches his most diabolical plot ever. The inmates of Arkham have been set free - and it’s up to Batman to bring order to the chaos and take back the asylum.

Using his combat skills, stealth and gadgets, it’s up to Batman to thwart Joker’s fiendish plans before it’s too late. Batman: Arkham Asylum lets you explore the depths of Arkham Island as you experience the darkest journey of Batman’s life.

Key Features:

• Square off against some of Gotham’s most notorious lunatics, including Harley Quinn, Killer Croc and Poison Ivy.

• Deploy an arsenal of upgradable gadgets, from a remote-control Batarang to a grappling gun and explosive gel.

• Use Detective Mode to identify important objects and reveal enemies’ weak spots.

• Deliver brutal combos with the innovative FreeFlow™ combat system.

• Move in the shadows and strike fear amongst your enemies.

• Solve the Riddler’s devilishly difficult puzzles to unlock challenge levels and trophies.

• Explore Arkham Island and discover its gruesome secrets through hidden items and character biographies.

• Winner of numerous awards including BAFTA Game of the Year and Outstanding Achievement in Game Design awards from the Academy of Arts & Sciences.

• Written by Paul Dini and featuring the voice talents of Mark Hamill and Kevin Conroy.

• Conquer six additional challenge maps and even play as the Joker! Batman: Arkham Asylum on the Mac contains all the DLC and expansion packs.

Important information regarding Batman: Arkham Asylum:

• Please note that we cannot reply to comments or questions left in Mac App Store reviews. If you require assistance, please contact our support team at support@feralinteractive.com

• Supports over 100 different models of gamepad. For a full list check the Feral support site.

• Minimum System Requirements: Processor: 2.0GHz Intel, RAM: 4.0GB, Graphics: 256MB, Free Space: 10.0GB.

• The following graphics cards are not supported: ATI X1xxx series, Intel GMA series, NVIDIA 7xxx series, NVIDIA 9400.

• The following graphics cards require 8GB of system RAM: Intel HD3000, NVIDIA 320M.

• This game is not currently supported on volumes formatted as Case-sensitive.

• You can find out more about the game on the Batman: Arkham Asylum mini-site at feralinteractive.com/bmaa

BATMAN: ARKHAM ASYLUM Software © 2009-2011 Warner Bros. Entertainment Inc. Developed by Rocksteady Studios Ltd. Published for the Mac by Feral Interactive Ltd. under license from Warner Bros. Entertainment Inc. Rocksteady and the Rocksteady logo are trademarks of Rocksteady Studios Ltd. Powered by Unreal Engine. Unreal ® is a registered trademark of Epic Games, Inc. Unreal ® Engine, Copyright 1998-2011, Epic Games, Inc. Uses FMOD Ex Sound System. Firelight Technologies. Uses Scaleform GFx © 2009-2011Scaleform Corporation. Portions of this software utilize SpeedTree® RT technology (© 2007-2011 Interactive Data Visualization, Inc.). SpeedTree® is a registered trademark of Interactive Data Visualization, Inc. Mac and the Mac logo are trademarks of Apple Inc. registered in the U.S. and other countries. Feral and the Feral logo are trademarks of Feral Interactive Ltd. All other trademarks and copyrights are the property of their respective owners. All rights reserved.

What's New in Version 1.1.1

• Restores support for the Polish and Russian languages

Screenshots

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4
Screenshot 5
Batman: Arkham Asylum
View in Mac App Store
  • SR 74.99
  • Category: Games
  • Updated:
  • Version: 1.1.1
  • Size: 9.17 GB
  • Languages: English, French, German, Italian, Polish, Russian, Spanish
  • Developer:
You must be at least 17 years old to download this application.
  • Infrequent/Mild Mature/Suggestive Themes
  • Frequent/Intense Realistic Violence
  • Infrequent/Mild Alcohol, Tobacco, or Drug Use or References
  • Frequent/Intense Profanity or Crude Humor

Compatibility: OS X 10.9.5 or later

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.