iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download Build Cars with Edward and Arthur by PlayWithMotion, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Build Cars with Edward and Arthur

By PlayWithMotion

Open iTunes to buy and download apps.

Description

This game is awesome for kids 3-7 years old, and works fine on iPad 2 and later, as well as iPhone 3Gs and later.

***** REVIEWS:
5 out of 5 - Best Apps for Kids (US)
5 out of 5 - Kinder App Garden (GERMANY)
5 out of 5 - Pappas Appar (SWEDEN)

In this game your child can create thousands of unique, crazy and fantastical cars and then test-drive them on the race track.

Nice 3d-rendered graphics and sound make the cars look and feel like real miniature cars and depending on what parts you use the car will behave different when driving. You’ll need better tires to splash through mud, bigger engine to go faster etc.

While playing you’ll collects stars, that unlocks more car parts, and even additional race tracks!

What's New in Version 1.1

- Supports iOS 6
- Should support iPhone 5 screen size

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
iPad Screenshot 5
Build Cars with Edward and Arthur
View In iTunes
This app is designed for both iPhone and iPad
  • $0.99
  • Category: Games
  • Updated:
  • Version: 1.1
  • Size: 21.5 MB
  • Languages: English, Czech, Dutch, French, German, Italian, Japanese, Korean, Polish, Portuguese, Russian, Simplified Chinese, Spanish, Swedish, Traditional Chinese, Turkish
  • Seller:

Compatibility: Requires iOS 4.0 or later. Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPhone 5c, iPhone 5s, iPhone 6, iPhone 6 Plus, iPad, iPod touch (3rd generation), iPod touch (4th generation), and iPod touch (5th generation).

Customer Ratings

Current Version:
All Versions: