iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download Flashback - Sci-Fi Style Calendar by OCTUDIO, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Flashback - Sci-Fi Style Calendar

By OCTUDIO

Open iTunes to buy and download apps.

Description

-----------------------------------------------------------------------------
We have just released limited edition. (free of charge but includes advertisement)(https://itunes.apple.com/us/app/flashback-sci-fi-style-calendar/id1078820264?l=ja&ls=1&mt=8)

To commemorate this, we take price reduction campaign for this unlimited edition for a week.
-----------------------------------------------------------------------------

The app offers you an unprecedented experience, just like in a movie.

Flashback is a calendar app with a design that can be seen in a SCi-Fi Film scene.

Intuitive controls make it easy to add or edit events.

This app requires iOS 9 or later, and iPhone 5 or later.

Please view this page to learn how to use this app.

http://flashback-calendar.com/usage

What's New in Version 1.3

fixed problems:
- layout broken on iOS9
- and inside, there were many legacy code they are deprecated on latest iOS. so removed them.

iPhone Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5

Customer Reviews

Unique

It is a shame this app does not get more recognition. Beautiful and well thought out.

Flashback - Sci-Fi Style Calendar
View in iTunes
  • $1.99
  • Category: Productivity
  • Updated:
  • Version: 1.3
  • Size: 4.0 MB
  • Languages: English, French, German, Italian, Japanese, Korean, Simplified Chinese, Spanish, Traditional Chinese
  • Seller:

Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.
All Versions: