iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download FSA-OWI: Dorothea Lange by Marc Rochkind, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

FSA-OWI: Dorothea Lange

By Marc Rochkind

Open iTunes to buy and download apps.

Description

Over 3,800 Dorothea Lange photographs that you can view, download, and print.

An internet connection is required.

Dorothea Lange was perhaps the best-known photographer working for the Farm Security Administration (FSA) from about 1933 to 1939, mostly because of her iconic photograph Migrant Mother (see screenshots). But she did a lot of other fine work, too.

This app shows essentially all of the digitized Dorothea Lange photographs in the Library of Congress archive, over 3,800 photographs in all. Each has the Library of Congress caption and date.

You can view the photos in an adjustable-size grid (with full captions), full-screen, or as a slideshow. You can also save any photo to your Photo Library, browse to the Library of Congress record for the photo, or order prints.

While all of these images can also be accessed on the LoC site, this app presents them in a much more convenient and organized way.

What's New in Version 1.2

Bug fixed -- images failed to appear.

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPad Screenshot 1
iPad Screenshot 2
FSA-OWI: Dorothea Lange
View in iTunes
This app is designed for both iPhone and iPad
  • $1.99
  • Category: Photo & Video
  • Updated:
  • Version: 1.2
  • Size: 12.8 MB
  • Language: English
  • Seller:
Rated 9+ for the following:
  • Infrequent/Mild Mature/Suggestive Themes

Compatibility: Requires iOS 5.1.1 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.