iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To buy and download John Titor by daisyprincess.com, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

John Titor

By daisyprincess.com

Open iTunes to buy and download apps.

Description

In 2009 an anonymous author wrote a book called Conviction of a Time Traveler. He goes by the name Temporal Recon when online. This app was created to be the best way for followers of the John Titor story to keep up with all the latest news. Here you'll be able to view the original John Titor online posts, view quotes from John as well as others involved the story, and where to buy the book and learn the latest evidence proving beyond any doubt John titor was exactly what he said he was: a time traveler. This is also the gateway to the re-release of the book that is coming soon. It contains even more information that's been uncovered since the writing of the book. This app will also keep you up-to-date on the movie that uses the book's author as a technical expert and his book as a technical reference. With this app you'll stay tied into the ongoing findings, keep up on Twitter, Facebook, or the blog. You want to know about the John Titor story? This is the app for you.

What's New in Version 1.1

Bug Fixing.

Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPad Screenshot 1
iPad Screenshot 2
iPad Screenshot 3
iPad Screenshot 4
John Titor
View In iTunes
This app is designed for both iPhone and iPad
  • $0.99
  • Category: Reference
  • Updated:
  • Version: 1.1
  • Size: 3.3 MB
  • Language: English
  • Seller:

Compatibility: Requires iOS 4.0 or later. Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPhone 5c, iPhone 5s, iPhone 6, iPhone 6 Plus, iPad, iPod touch (3rd generation), iPod touch (4th generation), and iPod touch (5th generation).

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.