iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download the free app Routesy - Real-Time Bay Area Transit Predictions by Pixelcup, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download
iTunes for Mac + PC

Routesy - Real-Time Bay Area Transit Predictions

By Pixelcup

Open iTunes to buy and download apps.

Description

Routesy will help you find your way around the Bay Area's top transit systems -- San Francisco Muni, BART, Caltrain & AC Transit -- in real time!

Simply choose the line you want to ride, and Routesy will show you the closest stop or station, along with real-time prediction data to make sure you make it on time.

You can also bookmark your favorite stops to quickly get predictions immediately upon opening the app.

What's New in Version 4.7.2

- NEW: Added the new April 2017 Caltrain schedule
- FIXED: Miscellaneous bugs

iPhone Screenshots

iPhone Screenshot 1
iPhone Screenshot 2
iPhone Screenshot 3
iPhone Screenshot 4
iPhone Screenshot 5

Customer Reviews

Great

Crazy accurate updates on every bus in the city, and allows you to bookmark your favorite stops so you don't have to scroll all the way down to find the times. 10/10

I use it everyday

It's accurate and I use it all the time to see when my buses are coming. I like the dynamic updating of my location and also the ability to see more details if needed. Thanks!

Super helpful app

Not always accurate to the minute but definitely correct within 5 minutes most of the time.

Routesy - Real-Time Bay Area Transit Predictions
View in iTunes
  • Free
  • Category: Navigation
  • Updated:
  • Version: 4.7.2
  • Size: 83.4 MB
  • Language: English
  • Seller:

Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

Customer Ratings

Current Version:
All Versions: