Mac App Store

Mac App Store is the simplest way to find and download apps for your Mac.

To download Warhammer® 40,000®: Dawn of War® II from the Mac App Store, you need a Mac with OS X 10.6.6 or later. Learn More.

Warhammer® 40,000®: Dawn of War® II

By Feral Interactive Ltd

Open the Mac App Store to buy and download apps.

Description

In the grim darkness of the far future, there is only war.

Before you buy, expand this description to check the system requirements below.

The sinister science fantasy universe of Warhammer 40,000 comes to savage life with Dawn of War II on Mac and Linux.

It’s the 41st Millennium in the Sub-Sector Aurelia, a cluster of worlds on the edge of the Milky Way, where a battle of epic proportions is about to begin. As a newly promoted Force Commander of the Blood Ravens Chapter, it is your privilege to lead crack squads of Space Marines into battle against the forces of Orks, Tyranids and Eldar that threaten the Imperium of Man.

Driven by an innovative campaign narrative steeped in the lore of Warhammer 40,000, armies of technologically advanced warriors wage brutal war against remorseless enemies in a series of addictively fast-paced and visceral combat missions.

Important information regarding Warhammer® 40,000®: Dawn of War® II:

• Please note that we cannot reply to comments or questions left in Mac App Store reviews. If you require assistance, please contact our support team at support@feralinteractive.com

• Minimum System Requirements: Processor: 1.8GHz Intel, RAM: 4.0GB, Graphics: 512MB, Free Space: 18.0GB.

• The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, Intel HD3000, Intel HD5300, NVIDIA 3xx series, NVIDIA 9xxx series, NVIDIA 7xxx series, NVIDIA 8xxx series.

• The following graphics cards require 8GB of system RAM: Intel HD 515, Intel HD4000.

• This game is not currently supported on volumes formatted as Case-sensitive.

• You can find out more about the game on the Warhammer® 40,000®: Dawn of War® II mini-site at feralinteractive.com/dawnofwar2

Warhammer 40,000: Dawn of War II © Copyright Games Workshop Limited 2016. Dawn of War II, the Dawn of War II logo, GW, Games Workshop, Space Marine, 40K, Warhammer, Warhammer 40,000, 40,000, the ‘Aquila’ Double-headed Eagle logo, and all associated logos, illustrations, images, names, creatures, races, vehicles, locations, weapons, characters, and the distinctive likeness thereof, are either ® or TM, and/or © Games Workshop Limited, variably registered around the world, and used under license. This release was originally developed by Relic Entertainment and originally published by SEGA. SEGA, the SEGA logo, Relic Entertainment and the Relic Entertainment Logo are either registered trade marks or trade marks of SEGA Holdings Co., Ltd or its affiliates. All rights reserved. SEGA is registered in the U.S. Patent and Trademark Office. Developed and published for Mac by Feral Interactive Ltd. Mac and the Mac logo are trademarks of Apple Inc., registered in the U.S. and other countries. Feral and the Feral logo are trademarks of Feral Interactive Ltd. All other trade marks, logos and copyrights are the property of their respective owners.

What's New in Version 1.0.2

• Fixes an issue where the game would fail to close fully while signed in to a Feral Account
• Fixes a number of minor issues

Screenshots

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4
Screenshot 5

Customer Reviews

Cant Play

Just took an HOUR to download on my computer and now its saying my MacBook doesnt have the minimum specifications to play it. I want my $20 back!

ok

the game is really good but the download took about an hour

Warhammer® 40,000®: Dawn of War® II
View in Mac App Store
  • $19.99
  • Category: Games
  • Updated:
  • Version: 1.0.2
  • Size: 16.49 GB
  • Languages: English, Czech, French, German, Italian, Polish, Russian, Spanish, Traditional Chinese
  • Seller:
You must be at least 17 years old to download this app.
  • Frequent/Intense Cartoon or Fantasy Violence
  • Frequent/Intense Realistic Violence

Compatibility: OS X 10.11.6 or later

Customer Ratings

We have not received enough ratings to display an average for the current version of this application.
All Versions: