iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

Cold Shadows (Ellie Jordan, Ghost Trapper Book 2)

no. 2, Ellie Jordan, Ghost Trapper - Ellie Jordan, Ghost Trapper

This book can be downloaded and read in iBooks on your Mac or iOS device.

Description

The second book in the Ellie Jordan, Ghost Trapper series.

Footsteps in the attic. Toys that play by themselves. A dark presence in an upstairs room.

Paranormal investigator Ellie Jordan faces a difficult new case. Her new clients are a family haunted by multiple ghosts and a poltergeist that wrecks their home at night. Their seven-year-old son’s invisible friends may not be imaginary at all, but the restless spirits of dead children.

To clear her clients’ house of the dangerous entities, Ellie must unravel the mysterious deaths of another family who lived in the old mansion more than a hundred and sixty years ago—and she must do it before the ghosts can carry out their malevolent designs on her clients and their children.

Customer Reviews

Worth It!

Great author! These books are a great buy! Just like the first I couldn't put it down!!!

Cold Shadows (Ellie Jordan, Ghost Trapper Book 2)
View in iTunes
  • $2.99
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Ghost
  • Published: Nov 13, 2014
  • Publisher: JL Bryan
  • Seller: Smashwords
  • Print Length: 231 Pages
  • Language: English
  • Series: no. 2, Ellie Jordan, Ghost Trapper
  • Requirements: To view this book, you must have an iOS device with iBooks 1.3.1 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.

Customer Ratings