iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening Apple Books.If Apple Books doesn't open, click the Books app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

Highmage

This book can be downloaded and read in Apple Books on your Mac or iOS device.

Description

Mages and their elflord kin gather for Conclave at the Mage Guild Hall in the seven Tiered Imperial Capital, home to elfbloods, dwarves, ogres, and lowly humans. George is now one of two candidates for Highmage. The other is backed by elvin traditionalists and is the unknowing puppet of the Demonlord, who schemes are about to bring about civil war.

Fate hinges on George’s unlikely allies: Gallen, the leader of a the pack of urchins, who is not what he appears; his apprentices - the elfblooded lad, Aaprin, who cannot do magic; the mischievous “twin” boys Revit and Terus; his sword-wielding female bodyguards; shape-changing foster-daughter, Raven; an ogress who remembers navigating a starship, and, for some reason, his horse, Babylon.

George has no wish to be responsible for saving this world where, in the distant past, magic twisted the laws of science, but destiny seems to have other plans. His computer staff reminds him that returning home through the Gate is looking better and better.

Welcome to Highmage, the fourth book in the Highmage’s Plight Series.

(Book 3 - Human Mage, debutting here on October 1, 2015, check www.dhr2believe.net for the details!)

Highmage
View in iTunes
  • $4.99
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Epic
  • Published: Oct 01, 2015
  • Publisher: D.H. Aire
  • Seller: Draft2Digital, LLC
  • Print Length: 395 Pages
  • Language: English
  • Requirements: This book can only be viewed on an iOS device with Apple Books on iOS 12 or later, iBooks 1.3.1 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.

Customer Ratings

We have not received enough ratings to display an average for this book.