iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

The Duke of Her Desire

Diamonds in the Rough

This book can be downloaded and read in iBooks on your Mac or iOS device.

Description

He was only supposed to keep an eye on his friend’s sister . . . now he’s about to lose his heart . . .

When Thomas Heathmore, Duke of Coventry, agrees to steer his friend’s inexperienced younger sister through society, he doesn’t expect the lady in question to be so infernally stubborn. Amelia Matthews seems to have little interest in balls or suitors at all. Instead, she intends to open a school, and against his better instincts, Thomas offers to help. Yet somewhere along the line, Amelia ceases to be a simple responsibility . . . and becomes an undeniable temptation.

Since her brother inherited a dukedom, Amelia’s prospects have transformed. But though she’s long been secretly infatuated with Thomas, she refuses to heed the arrogant aristocrat’s advice. If only it were as easy to ignore his heated touch. And as Amelia soon learns, the ton is a minefield, where one moment’s indiscretion can unleash a scandal—or entice her to surrender everything to the duke of her desire . . .

The Duke of Her Desire
View in iTunes
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Historical
  • Expected Release: Dec 26, 2017
  • Publisher: Avon
  • Seller: HarperCollins
  • Print Length: 384 Pages
  • Language: English
  • Requirements: To view this book, you must have an iOS device with iBooks 1.5 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.