iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

The Last Spell

4, The Thickety

This book can be downloaded and read in iBooks on your Mac or iOS device.

Description

The spellbinding conclusion in the critically acclaimed Thickety series, perfect for fans of Neil Gaiman. In The Thickety #4: The Last Spell, Kara and her brother Taff must find the hidden pieces of Princess Evangeline’s grimoire to defeat Rygoth and her army of witches in one last good versus evil battle.

Kara and Taff have discovered that the Spider Queen is searching for Princess Evangeline’s grimoire—the Vulkera. Legends say that any witch who wields its dangerous magic would be indestructible. Kara and Taff have to stop the Spider Queen from finding the ancient weapon—and destroying everything.

They will travel through time with an old enemy, come face-to-face with the creatures that guard the grimoire’s pages, and unravel a king’s dangerous secret, before one final battle against the Spider Queen. But can Kara save the people she loves and cast a spell that could change magic forever?

Other Books in This Series

The Last Spell
View in iTunes
  • $6.99
  • Level: Grades 5 and Above
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Fantasy
  • Published: Apr 04, 2017
  • Publisher: Katherine Tegen Books
  • Seller: HARPERCOLLINS PUBLISHERS
  • Print Length: 512 Pages
  • Language: English
  • Series: 4, The Thickety
  • Requirements: To view this book, you must have an iOS device with iBooks 1.5 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.

Customer Ratings