iTunes

Opening the iTunes Store.If iTunes doesn't open, click the iTunes application icon in your Dock or on your Windows desktop.Progress Indicator
Opening the iBooks Store.If iBooks doesn't open, click the iBooks app in your Dock.Progress Indicator
iTunes

iTunes is the world's easiest way to organize and add to your digital media collection.

We are unable to find iTunes on your computer. To download from the iTunes Store, get iTunes now.

Already have iTunes? Click I Have iTunes to open it now.

I Have iTunes Free Download

The Problem with Crazy

#1, Crazy in Love

This book can be downloaded and read in iBooks on your Mac or iOS device.

Description

The problem with crazy was that crazy, by itself, had no context. It could be good crazy, bad crazy ... or crazy crazy—like it was when my ex-boyfriend sung about me on the radio.
   Eighteen-year-old Kate couldn’t be more excited about finishing high school and spending the summer on tour with her boyfriend’s band. Her dad showing up drunk at graduation, however, is not exactly kicking things off on the right foot—and that’s before she finds out about his mystery illness, certain to end in death.
   A mystery illness she could inherit.
Kate has to convince everyone around her that her father is sick, not crazy. But who will be harder to convince? Her friends? Or herself?
   The Problem With Crazy is a story about love and life; about overcoming obstacles, choosing to trust, and learning how to make the choices that will change your life forever.

Customer Reviews

Emotional and stunning

This book sucked me in, made me FEEL every ounce of the character's emotions, and left me changed. Beautiful work.

Other Books in This Series

The Problem with Crazy
View in iTunes
  • $2.99
  • Available on iPhone, iPad, iPod touch, and Mac.
  • Category: Contemporary
  • Published: Feb 13, 2014
  • Publisher: Lauren K. McKellar
  • Seller: Draft2Digital, LLC
  • Print Length: 330 Pages
  • Language: English
  • Series: #1, Crazy in Love
  • Requirements: To view this book, you must have an iOS device with iBooks 1.3.1 or later and iOS 4.3.3 or later, or a Mac with iBooks 1.0 or later and OS X 10.9 or later.

Customer Ratings